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Introduction
This document guides you through the setup of the three tiers of a working Active Enterprise installation. The three tiers and their major components are:
· Database tier. This comprises a database engine such as SQL Server or Oracle, and any MooD repository database.
· Business Integration Engine (BIE) tier. This comprises the Business Integration Engine, MooD 15, and optionally Microsoft Excel.
· Active Publisher (AP) tier. This comprises Active Publisher, MooD 15, Internet Information Services, and ASP.NET 2.0.
The three tiers can run on separate machines if required, but consideration should be given to the overhead introduced by these tiers communicating over a local area network rather than locally on a single machine. A single server installation is simpler to install and enhances performance (due to not having to communicate over the network), but could introduce a performance bottleneck if the solution you are deploying places a high load on any one of the tiers.

Steps to Deploy Active Enterprise Server
This document covers the different ways you can install BIE and Active Publisher. It is arranged in tasks. Each task brings your deployment closer to readiness and is described in its own section in this document. To successfully install Active Enterprise Server, perform the tasks (section 2 to 10) in order. Sections 11 onwards cover particular situations that might be relevant to you.

Release Notes
The latest version of the release notes should be consulted for any further notes and for the latest hardware recommendations.




1. [bookmark: _bookmark0]Software Requirements

Operating System:
You can install these products on the following server operating systems:
· Microsoft Windows 2003 R2 Server.
· Microsoft Windows 2008 Server.
· Microsoft Windows 2008 R2 Server.
The recommended operating system is Microsoft Windows Server 2008 R2 (64bit).
For demonstration purposes only, you can install these products on the following workstation operating systems:
· Windows XP Professional 32-bit SP2 or SP3.
· Windows Vista.
· Windows 7 Ultimate, Enterprise or Business Editions.
NOTE: These platforms are not suitable for live deployments.
In all cases, it is recommended that the latest service pack and patches are applied to the server.
Internet Information Server: On the AP tier, Internet Information Server (IIS) version 6.0 or greater must be installed.
MooD: MooD 15 must be installed on both the BIE and AP tiers.
Microsoft .NET Framework: MooD 15, BIE, and AP all require Microsoft .NET Framework 2.0 Service Pack 2. This framework may already be installed, but, if not, it will be installed with the products.
Microsoft XML: MooD 15 requires Microsoft XML v 6.0 SP1. If it is not installed, it will be installed with the products.
SQL Control Types 2008 R2 SP1: required by MooD 15, and will be installed if not already present.
SQL Management Objects 2008 R2 SP1: required by MooD 15, and will be installed if not already present.
SSCERuntime Package: required by MooD 15, and will be installed if not already present.
AJAX extensions for .Net: required by MooD 15 and AP tiers, and will be installed if not already present.
Microsoft Office: On the BIE and AP tiers, Microsoft Excel 2003 or later may be required if your solution uses the Excel import synchronization activator configured to run in Excel Native mode.



Business Integration Engine (BIE)


2. [bookmark: _bookmark1]Install a Database Engine

2.1	Install Microsoft SQL Server as the Database Tier
Databases can be hosted on SQL Server 2005, SQL Server 2008, SQL Server 2008 R2 or SQL Server 2012. Express versions can be used for demonstration purposes only, but they are not suitable for live deployment. The recommended option is SQL Server 2008 R2 Enterprise SP1 (64bit). All SQL Server products require the same installation choices.

2.1.1	Ensure that mixed mode authentication and full text indexing is selected as part of the installation procedure.
2.1.1 Be sure to remember the SA password that you choose.
2.1.2 If the BIE server and SQL Server are on different machines, open a TCP port on the SQL server machine firewall so the BIE can connect to the database. For SQL Server, the default port is 1433.
2.1.3 Configure SQL Server to accept TCP/IP connections;
2.1.3.1 From the Start menu, open SQL Server Configuration Manager.
2.1.3.2 In the right-hand panel, browse to the protocols for your SQL Server instance.
2.1.3.3 In the right-hand panel, right-click TCP/IP.
2.1.3.4 Choose Enable.
2.1.3.5 Stop and start the SQL Server service.

Refer to your Microsoft support team for more assistance.

2.2 Install Oracle as the Database Tier
Databases can be hosted on Oracle 10g and 11g (using the appropriate 32bit driver). Full text indexing must be installed.
Please refer to your Oracle support team for help installing Oracle.
If the BIE server and Oracle are on different machines, open a port so the BIE can connect to the database. For Oracle, the default port is 1521.


3. [bookmark: _bookmark2]Install and Licence MooD 15

Perform a custom installation of MooD 15 to not include the installation of SQL Server Express, and ensure it is available to everyone who uses this computer. More details of this procedure can be found in the MooD Release Notes.
Note that the InstallShield wizard will check that certain prerequisites are installed on the machine and install them if necessary. On 64 bit installations, the status of this check will progress through Pending > Installed > Succeeded even if the prerequisites are already installed
Start MooD 15 Repository Manager. On the File tab, click Manage Licence and install a licence file (using a Licence Server is not supported for Active Enterprise Server installations). See the Repository Manager Guide for details.




4. [bookmark: _bookmark3]Configure Repository Server and Create or Restore a Repository

Start MooD 15 Repository Manager, add the Database Engine Server and create or restore a repository. See the Repository Manager Guide for details. The next section gives some additional guidance for SQL Server.
In whatever repository you create or restore, it is advisable to locate or create some content to assist with testing the Active Enterprise setup, for example, a Home page for Administrator.
4.1	SQL Server
Key points and guidance:
· We recommend running Repository Manager as Administrator. Right click the MooD 15 icon and select Run as Administrator.
· To create a new database, you must have a connection to the server, and the user credentials used must have administrative privileges on SQL Server. In Repository Manager, when you add a server, on the Add Server dialog box on the Servers tab, make sure Security is set to use Native SQL Authentication.
· Use the Test button on the Add Server dialog box to test the credentials and server name. If the test fails, check the details you have supplied.
· If you supplied SQL Server sysadmin user credentials when you added the server, you can create a repository immediately. If not, you will need to provide sysadmin credentials in the Add Repository dialog box. This will be cached for the duration of the Repository Manager session, but, for subsequent sessions, will revert to the credentials provided when the server was added.




· If you do not have access to a sysadmin user, on the Add Repository dialog box, select the Create SQL script only checkbox and then give the script created to your database administrator (DBA). The DBA can use this script to create the repository for you. The DBA must use sysadmin privileges to ensure that the correct user is assigned the correct role.
· For normal connection to the SQL repository, the SQL login that is used to access the SQL database must only be associated with the RepName_role database role for that database. This role is created by MooD upon database creation. If the database is renamed, this role will also need to be renamed accordingly.
· Once the repository has been created in SQL Server, it should be visible to Repository Manager. On the Server tab, select the server, and then click Find all repositories on the selected server. If SQL authentication as listed above is supplied, the repository will be listed. Set it to Show to make it visible on the Repositories tab.




5. [bookmark: _bookmark4]Install the Business Integration Engine (BIE)

5.1.1 Install the Business Integration Engine;
5.1.1.1 Using the MooD Media, navigate to the Business Integration Server/Business Integration Engine folder and run the setup.exe file.
5.1.1.2 Review and accept the licence agreement.
5.1.1.3 Select an installation folder for BIE (the default is recommended), and ensure it is available to everyone who uses the computer.

NOTE:
· If the BIE server and Active Publisher server are on different machines, configure your firewall to open a port so that Active Publisher can connect to the BIE. By default, this is port 50015, and is configurable in the BIE’s config.xml file.
· If the port is changed from the default, it will also need to be changed in Business Architect. In the Explorer Bar, under Libraries, click Web Publishing. Select the Active Publish profile, and then, on the ribbon, click Edit and change the port selected.








6. [bookmark: _bookmark5]Cache a Repository in Business Integration Engine (BIE)

6.1.1 It is advisable to validate the repository for publishing (but not required);
6.1.1.1 In MooD Repository Manager, right click the repository, and then click Validate.
6.1.1.2 Provide the repository administrative credentials.
6.1.1.3 Select Check & Fix errors and then click Next (this may take some time).
6.1.1.4 If there are any errors highlighted, contact MooD International support for advice.
6.1.2 It is advisable to defragment all indices (but not required);
6.1.2.1 In MooD Repository Manager, right click the repository, and then click Index Fragmentation.
6.1.2.2 Click Defragment All and then click OK.
6.1.3 Ensure BIE service is started;
6.1.3.1 Navigate to Control Panel > Administrative Tools > Services.
6.1.3.2 Locate and start the service named Business Integration Engine 15.
6.1.3.3  (
net start bie_15
)Alternatively, run this command from a command line;
6.1.4 Use the BIE Manager to create a cache of the desired repository;
6.1.4.1 Open the BIE Manager. Use Start > All Programs > MooD 15 >
Business Integration Engine Manager.
6.1.4.2 Ensure the BIE Server and BIE Port number boxes are correct, and then click Connect.
6.1.4.3 Select the required repository and then select Enable support for BIE. Enter the repository administrator username and password, choose a security provider from those installed, select the plug-in(s) you wish to enable for the repository, and then click Apply.
It is possible to install other security providers. See the Install a New Security Provider section on page 18 for details.



[image: ]


6.1.4.4 The repository status will change to The repository is ready.



Active Publisher


7. [bookmark: _bookmark6]Install Internet Information Server (IIS)

Both IIS and ASP.NET are required by the Active Publisher tier. For further guidance on IIS installation, contact your Microsoft support team.

7.1 Windows Server 2003 and XP Installation
7.1.1 IIS is installed using the Add or Remove Programs dialog in Control Panel. Use the Add or Remove Windows Components tab.
7.1.2 If .NET 2.0 Service Pack 2 has been installed prior to the installation of IIS, you must run the following command to re-register ASP.NET.
7.1.2.1 Open the command prompt dialog. Click Start > Run and in the Run dialog type cmd and then press Enter. This opens the command prompt dialog. (If running on Vista and UAC is turned on then you will need to run cmd as Administrator.)
7.1.2.2  (
CD C:\windows\Mic
rosoft.NET\Framework\v2.0.50727 aspnet_regiis.exe -
i
exit
)In the command prompt dialog, enter the following commands; (Each line is a single command. Press Enter after each. The exit command closes the command prompt dialog.)

7.2 Windows Vista / Windows 7 Installation
7.2.1 IIS is installed using the Turn Windows Features on or off dialog in Control Panel (in the Programs and Features section).
7.2.2 Select the Internet Information Services item to install IIS with default features enabled. The following additional sub-features must also be enabled:
· Web Management Tools > IIS 6 Management Compatibility > IIS 6 Metabase and IIS 6 configuration compatibility
· World Wide Web Services > Application Development Features
> ASP.NET
7.2.3 For installations utilising integrated authentication, the following is also required:
· World Wide Web Services > Security > Windows Authentication




7.3 Windows Server 2008 Installation
7.3.1 IIS is installed using the Roles section in the Server Manager application.
7.3.2 In the Roles Summary click Add Roles and select the Web Server (IIS)
role.
7.3.3 When prompted, select Role Service. In addition to the defaults, the following must be selected:
· Web Server > Application Development > ASP.NET
· Management Tools > IIS 6 Management Compatibility > IIS 6 Metabase Compatibility
7.3.4 For installations utilising integrated authentication, the following is also required:
· Web Server > Security > Windows Authentication




8. [bookmark: _bookmark7]Install Active Publisher

Follow the steps below to install the first instance of Active Publisher on a server. For information on installing additional instances see section 13.

8.1 Installation
8.1.1 Using the MooD Media, navigate to the Business Integration Server/Active Publisher folder and run the setup.exe file.
8.1.2 Review and accept the licence agreement.
8.1.3 During the installation you will be prompted to create an application pool in IIS. Allow this. When you configure IIS, you can use this pool, or add additional pools.
8.1.4 Set Site and Virtual Directory appropriately. Virtual Directory is used to build up the web address for Active Publisher. For example, if you are installing on a machine called WebServer and install to a virtual directory called MyRepository, you would access Active Publisher from http://WebServer/MyRepository. Port 80 will be used as the default port for IIS. Configuration of this port is possible using the IIS Management Console.


9. [bookmark: _bookmark8]Configure Internet Information Server (IIS)

9.1 Windows XP Configuration
9.1.1 Add the ASPNET user to the Administrators group.
9.1.1.1 Open Computer Management (run compmgmt.msc).
9.1.1.2 Find the ASPNET user (under System Tools > Local Users and Groups > Users).
9.1.1.3 Right-click the ASPNET user and select Properties. On the Member Of tab, add the user to the Administrators group.
9.1.2 [bookmark: _bookmark9]Set the ASP.NET version.
9.1.2.1 Open Internet Information Services (IIS) Manager (run inetmgr.exe).
9.1.2.2 Find the Active Publisher virtual directory (under Web Sites >
Default Web Site).
9.1.2.3 Right-click and select Properties. On the ASP.NET tab, ensure that
ASP.NET version 2.0.xxxxx is selected.

9.2 Windows Server 2003 Configuration
9.2.1 If running on the 64-bit edition of Windows Server 2003, switch to the 32-bit version of ASP.NET.
9.2.1.1  (
cscript
 %SYSTEMDRIVE%\
inetpub
\
adminscripts
\adsutil.vbs SET W3SVC/
AppPools
/Enable32bitAppOnWin64 1
exit
)Enter the following commands and press Enter (there are two commands (exit is the second));
9.2.2 [bookmark: _bookmark10]Enable the ASP.NET extension.
9.2.2.1 Open Internet Information Services (IIS) Manager (run inetmgr.exe).
9.2.2.2 Navigate down to Web Service Extensions, select ASP.NET v2.0.xxxxx from the list, and then click the Allow button.
9.2.3 [bookmark: _bookmark11]Create a new application pool. It is good practice to name application pools after the applications they will serve.
Note that the Active Publisher installation allows you to create an application pool during installation. If you did this, and you want to use that pool, you do not have to create a new pool. However, you should check that its settings match those of the one created here.
9.2.3.1 In Internet Information Services (IIS) Manager, navigate to Application Pools and create a new one (right click and select New) using the default settings.
9.2.3.2 Right click on the new application pool and select Properties. On the
Identity tab, select the Local System predefined user.



9.2.4 Assign Active Publisher to the new application pool and set the ASP.NET version.
9.2.4.1 In Internet Information Services (IIS) Manager find the Active Publisher virtual directory (under Web Sites > Default Web Site).
9.2.4.2 Right-click and select Properties.
9.2.4.3 On the Virtual Directory tab, in the Application settings section, select the application pool created in 9.2.3.
9.2.4.4 On the ASP.NET tab, ensure that ASP.NET version 2.0.xxxxx is selected.

9.3 Windows Server 2008, Windows 7 and Windows Vista Configuration
9.3.1 [bookmark: _bookmark12]Create a new application pool. It is good practice to name application pools after the applications they will serve.
Note that the Active Publisher installation allows you to create an application pool during installation. If you did this, and you want to use that pool, you do not have to create a new pool. However, you should check that its settings match those of the one created here.
9.3.1.1 Open Internet Information Services (IIS) Manager (run inetmgr.exe).
9.3.1.2 Navigate to Application Pools and create a new one (right click and select Add Application Pool). Ensure that .NET Framework version 2.0.xxxxx is selected.
9.3.1.3 Right click on the new application pool and click Advanced Settings. Under Process Model, set Identity to LocalSystem. If running on a 64-bit edition of Windows, also set Enable 32-bit Application to True.
9.3.2 [bookmark: _bookmark13]Assign Active Publisher to the new application pool.
9.3.2.1 In Internet Information Services (IIS) Manager find the Active Publisher virtual directory (under Sites > Default Web Site).
9.3.2.2 Right click the virtual directory and select Manage Application > Advanced Settings. Set the Application Pool to the one created in 9.3.1.
9.3.3 [bookmark: _bookmark14]If integrated authentication is to be used, it must be enabled for the virtual directory.
9.3.3.1 In Internet Information Services (IIS) Manager, select the Active Publisher virtual directory (under Sites > Default Web Site).
9.3.3.2 In the right-hand pane, under the IIS heading, select Authentication.
9.3.3.3 Right-click Windows Authentication, and then select Enable.
You will also need to ensure that your repository is configured to use Windows Authentication. See Section 14 Using Windows Authentication for details.








10. [bookmark: _bookmark15]Configure Active Publisher

10.1.1 [image: ]In the folder \Inetpub\wwwroot\<Virtual Directory>\bin, you will find the application ConfigureActivePublisher.exe. Double-click this to run the Active Publisher configuration tool (note that this program modifies the ActivePublisher.config file in the parent folder).
10.1.2 Under Repository, use the Name drop down list to choose the repository that this Active Publisher installation will serve, and set the appropriate administrator name and password for the repository (the MooD logon not the SQL logon).
10.1.3 The remaining settings can be accessed from within Business Architect. In the Explorer Bar, under Libraries, click Web Publishing. Select the Active Publish profile, and then, on the ribbon, click Edit.



[image: ]
10.1.4 Under BIE Server, set the BIE Port and BIE Server settings. If the BIE is installed on the same machine, the default settings (50015 and localhost) should be fine.
10.1.5 Click OK to accept the changes.
10.1.6 Active Publisher should detect the changed configuration and automatically restart. It can be manually restarted by entering iisreset from a command prompt.
You should now be able to view your repository by opening a web browser and navigating to localhost/NameOfApplication.





Appendices





11. [bookmark: _bookmark16]Troubleshooting

11.1 Business Integration Engine will not start
If, when starting the Business Integration Engine Service, it reports that the service could not be started, to find out what problems were reported, see the MooD application log in the event log. To see this use Control Panel > Administrative Tools > Event Viewer and select Application and Services Logs > MooD.

11.2 Business Integration Engine reports that it is not licensed
If, when connecting to the Business Integration Engine using the Business Integration Engine Manager, it reports that it is not licensed, make sure that MooD Repository Manager is started as the Administrator user (right click the icon and choose Run as administrator) and reinstall the licence file.

11.3 Cannot log in to an Active Published Repository
If, when trying to log into an Active Published repository using a username and password, you are always returned to the login page, make sure that Forms Authentication is enabled for the site.
If, when trying to log into an Active Published repository using integrated login, it doesn’t work, make sure that Windows Authentication is enabled for the site.








12. [bookmark: _bookmark17]Install a New Security Provider (optional)

The security providers are pluggable additions to Business Integration Engine and Active Publisher that control how the web users log into the Active Publisher website, and control the view and edit permissions on the content.
They are fully pluggable, and installation instructions should be included with the appropriate installation files. Contact your distributer or MooD International support for further details.




13. [bookmark: _bookmark18]Installing Additional Active Publisher Instances

It is possible to run multiple Active Publisher web sites using a single Business Integration Engine installation, up to a recommended maximum of six repositories per server (depending upon the size and complexity of the data and web pages, and the user usage patterns).

13.1 Adding a new Active Publisher Instance
13.1.1 Follow the steps in section 6 to cache the repository in BIE.
13.1.2 Copy the existing Active Publisher installation folder and give it an appropriate name, for example copy C:\InetPub\wwwroot\ActivePublisher to C:\InetPub\wwwroot\ActivePublisher2.
13.1.3 Convert the new Active Publisher folder into an application.
13.1.3.1 Open Internet Information Services (IIS) Manager (run inetmgr.exe).
13.1.3.2 For Windows Server 2003 and XP, right-click the folder and select Properties. On the Directory tab, in the Applications settings section, click the Create button.
13.1.3.3 For Windows Server 2008 and Vista, right-click the folder and select
Convert to Application.
13.1.4 Configure IIS for the new application.
13.1.4.1 For Windows XP, perform the steps in 9.1.2.
13.1.4.2 For Windows Server 2003, perform the steps in 9.2.2 and 9.2.3.



13.1.4.3 For Windows Server 2008 and Vista, perform the steps in 9.3.1, 9.3.2 and 9.3.3.
13.1.5 Configure the new Active Publisher instance. Follow the steps in section 10.

13.2 Separating Cookie Settings
For a user to be able to simultaneously log into multiple Active Publisher instances on the same domain, you must configure each instance to use a separate pair of cookies for session management and authentication.

13.2.1 For each Active Publisher instance, make the following changes.
13.2.1.1 Navigate to the root of the Active Publisher folder and open the
Web.config file.
13.2.1.2 Modify the name attribute of the forms element to an instance- specific value, for example:

<forms timeout="20" name="ActivePublisher2" loginUrl="Login.aspx" protection="All" />

13.2.1.3 Add a cookieName with an instance-specific value to the
sessionState element, for example:

<sessionState cookieName="ActivePublisherSession2" mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20" regenerateExpiredSessionId="true" />

Note that each name and cookieName setting must be unique both within and across all Web.config files.








14. [bookmark: _bookmark19]Using Windows Authentication

Provided IIS has been configured to allow the use of Windows Authentication (see section 9.3.3) you can configure a repository so that users can use their Windows Authentication to log in. How to do this is covered here.
14.1.1 Open the repository in Business Architect and navigate to any model.
14.1.2 On the ribbon, on the Web tab, click Settings.
14.1.3 In the Active Publishing Configuration dialog box, click the Security tab.
14.1.4 [image: ]Set User Authentication Mode to Integrated.
14.1.5 Click OK.
14.1.6 [image: ]You must now associate the correct Windows login name with each user in the Users theme. To do this, in Business Architect’s Explorer Bar, under Themes, under Users, open the user’s definition window and set the Windows Login Name setting.
The user should now be able to use their Windows Authentication to log into the MooD Active Enterprise site.







15. [bookmark: _bookmark20]Advanced Configuration

15.1 BIE
The Config.xml file in the BIE install location can be edited to turn on performance monitoring, out of process model publishing, and set the memory usage threshold before recycle or maximum number of Synchronization threads.
· monitor-performance=”true” – turns on the performance monitors in BIE so that perfmon can be used to monitor the performance of the service (by default this is off).
· memory-usage-threshold=”<percentage>” – sets the percentage threshold of used process memory to get to before the BIE synchronization execution recycles (the default is 90%).
· maximum-threads=”<number>” – sets the limit of Scheduled or MAE manually triggered synchronizations which are run concurrently. This can help overall system performance especially where BIE and AP are on the same machine. The default is 5 times the number of processor cores. This may need to be tuned according to the needs of the solution and hardware.
· in-process-model-publisher=”false” – tells Synchronizations that are publishing models or matrices to do this in a separate process. This can help BIE performance and reduce BIE synchronization execution recycling where large models or matrices are used.

The following registry keys can be created under
[HKEY_LOCAL_MACHINE\SOFTWARE\Salamander\Business Integration Engine\15]
· DisableFieldActivationTimers=<true|false> – Causes BIE to skip checking for scheduled field activations. This can help BIE startup time if the repository contains a large number of field activations.
· DisableSynchronizationTimers=<true|false> – Causes BIE to skip checking for scheduled synchronizations.
· SATThreadPoolSize=<number> - Limits the number of Scheduled or MAE manually triggered synchronizations which are run concurrently. This can help overall system performance especially where BIE and AP are on the same machine. Default is 5 times the number of processor cores. Note: The value of SATThreadPoolSize needs to be tuned according to the needs of the solution and hardware. This overrides anything set in the Config.xml.




15.2 AP
The following keys can be created under
[HKEY_LOCAL_MACHINE\SOFTWARE\Salamander\Active Publisher\15]
· Upload Folder=<Share> - (note the space between Upload and Folder). If using the file upload control and the BIE and AP are on different machines, you must specify a shared location for AP to store the uploaded file and from which BIE will pick up the file.




16. [bookmark: _bookmark21]Hardening Active Enterprise Installations

This section describes changes which can be made to the web.config file to harden an installation against malicious attack.

16.1 httpRuntime Modifications
Change the line:

<httpRuntime apartmentThreading="true" executionTimeout="300" />

to:

<httpRuntime apartmentThreading="true" executionTimeout="1200" enableVersionHeader="false" maxRequestLength="20480" />

This prevents the ASP.NET version being disclosed, increases the execution timeout (how long to wait for a request in seconds), and allows upload of large files.

16.2 Enforce SSL protection for cookies
Important - only make this change if your installation is using SSL/https, otherwise it will disable login altogether. Do NOT make this change if you only support http.

Change the line:

<forms timeout="20" name="ActivePublisher" loginUrl="Login.aspx" protection="All"/>

to:

<forms timeout="20" name="ActivePublisher" loginUrl="Login.aspx" protection="All" requireSSL="true"/>

By setting requireSSL="true", the secure cookie property is set. This determines
whether



browsers should send the cookie back to the server. With the secure property set, the cookie is sent by the browser only to a secure page that is requested using an HTTPS URL. For details, see http://msdn.microsoft.com/en- us/library/1d3t3c61(v=VS.80).aspx.

Add the following line below <system.web>:

<httpCookies httpOnlyCookies="true" requireSSL="true" />

This secures the BIE cookie so the cookie is sent by the browser only to a secure page that is requested using an HTTPS URL. For details, see http://msdn.microsoft.com/en-us/library/ms228262(v=VS.80).aspx.







17. [bookmark: _bookmark22]Upgrading to a later Build of MooD 15

Multiple builds of MooD 15 CANNOT co-exist on the same machine. If an upgrade is required, the BIE and AP tiers must be upgraded, along with the accompanying installation of Business Architect. The uninstallations MUST be completed in the following order.

17.1 Uninstall AP

Uninstall Active Publisher using the Windows Control Panel. Ensure that the virtual directory has been completely deleted at \inetpub\wwwroot\<virtual Directory>.

17.2 Uninstall BIE

Uninstall Business Integration Engine using the Windows Control Panel.

17.3 Uninstall MooD Business Architect

Uninstall MooD 15 using the Windows Control Panel.

17.4 Reinstallation

Reinstall in accordance with this guide.
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